Back to Silas S. Brown's home page

Download 4DML Transformation Utility

Back to 4DML home page

The source is distributed under the terms of the GNU General Public License.  The author does not provide technical support, but would like to know of any projects that 4DML is used in.

What You Will Need

  1. Python, preferably version 2.1+ (the program is not tested on earlier versions, although some parts might work).  See www.python.org, or your package management software if you are on Unix/Linux.
  2. Expat (a library for parsing XML).  The program can partially work without it, but XML reading won't be available and various other things might not work so well.  In Debian Linux, Expat is (at the time of writing) in the packages python2.1-xmlbase and python2.2-xmlbase.
The following packages are optional:
  1. wxPython.  This is only needed if you want to run the GUI; you don't have to install it otherwise.
  2. Psyco, the Python Specialising Compiler.  4DML will use this if present, and it can speed up some tasks (particularly large ones) at the expense of memory.  Note that for this to be effective you must be running at least version 2.2 of Python.

Installation instructions

For Unix/Linux there is a script that installs the commands, `man' pages, and `info' pages.  Run cd 4dml; ./Install.sh as root, and then the 4dml command should be available.  (If you don't have root access, change the variables at the start of Install.sh to suit your directory structure.)

For other platforms you can run Python on main.py with the appropriate command-line arguments.  The documentation is available in manual.html.

Download 4DML transformation utility (gzipped tar archive)


All material © Silas S. Brown unless otherwise stated.